[Thinlinc-technical] thinlinc with gnome-keyring

Justin Garrison justinleegarrison at gmail.com
Thu Feb 4 19:49:45 CET 2016

> I should have read Philippe's response more thoroughly, it seems like
> the daemon command itself has some options. So this might work if run
> from inside the session:
>   tl-sso-password | gnome-keyring-daemon --unlock
> Rgds

​Thanks for the tip on tl-sso-password. That's getting me closer to what I
need but I'm still trying to figure out gnome-keyring oddities. For some
reason --unlock doesn't unlock the actual login keychain (the one prompting
for a password) no matter what I try. I also tried shutting down all of the
keyring daemons and then running

export $(tl-sso-password | gnome-keyring-daemon --login)

>From within the thinlinc session and whenever I run seahorse the login
keyring is still locked. I also tried some other combinations for the
daemon with --replace and running in the foreground but couldn't get it to
I know this part isn't a thinlinc issue though because I can't get my login
keyring to unlock even on the local session when manually starting the
keyring daemon.
I'll keep poking around and see if I can figure out the login keychain
unlocking. Or at least get it to prompt for a password.​
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cendio.se/pipermail/thinlinc-technical/attachments/20160204/5e412197/attachment-0003.html>

More information about the Thinlinc-technical mailing list