[Thinlinc-technical] thinlinc with gnome-keyring

Philippe BOURDEU d'AGUERRE bda at aime-toulouse.fr
Tue Feb 2 08:59:01 CET 2016

Sorry, I don't have any solution but I have same problem with Centos 6. 
I tried also to modify /etc/pam.d/thinlinc file with same result.

I noticed that with gdm gnome-keyring-daemon starts with "--daemonize" 
and "--login" commandline parameters and that with thinlinc 
gnome-keyring-daemon starts with only "--daemonize" parameters
AIME - Campus de l'INSA			http://www.aime-toulouse.fr/
135 av. de Rangueil			Tél +33 561 559 885
31077 TOULOUSE Cedex 4 - FRANCE		Fax +33 561 559 870

Le 01/02/2016 20:52, Justin Garrison a écrit :
> I'm using thinlinc on CentOS/Redhat 7 hosts. The problem is after login
> via thinlinc I am prompted for my keyring password because the login
> password was not properly passed to pam_gnome_keyring to unlock it
> automatically. This problem doesn't happen from gdm or lightdm on the
> local machine and they gnome-keyring-daemon is already authenticated
> after login.
> I tried adding the necessary lines to /etc/pam.d/thinlinc
> auth       optional    pam_gnome_keyring.so
> and
> session    optional    pam_gnome_keyring.so auto_start
> according to https://wiki.gnome.org/Projects/GnomeKeyring/Pam/Manual but
> I am still prompted for my password after login. I also tried to disable
> the keyring but too many applications integrate with it for password
> storage so the keyring needs to be running otherwise the
> gnome-keyring-daemon starts when the applications start.
> I also tried replacing /etc/pam.d/thinlinc with the lightdm
> configuration file to see if it would work similarly but it did not.
> Is there a way to have the gnome-keyring properly unlocked at login with
> thinlinc without using a blank password for the keyring login store?
> --
> Justin Garrison

More information about the Thinlinc-technical mailing list